Annonce

Faites la différence entre le service WordPress.com et l'application libre WordPress.

Mettez-vous à jour ! WordPress 3.9 est disponible en français.

Annonce 1 : Le Codex en français a besoin de vous pour avancer !
Annonce 2 : Avant de poster, n'oubliez pas de faire une petite recherche et de lire les règles de ce forum.
Annonce 3 : Lisez notre blog, il regorge de bonnes informations.
Annonce 4 : Rejoignez-nous sur Facebook, Google + et sur Twitter

#51 08-02-2010 11:33:42

Lumière de Lune
Admin nomade
Lieu: El Jadida
Date d'inscription: 15-08-2007
Messages: 15970
Site web

Re: PHP5 depuis WordPress 2.8

Le fichier .htaccess n'est généré par wordpress que si vous avez une structure de permallien mise en place.
si c'est le cas, alors il se peut qu'il soit tout simplement un fichier "invisible", à vérifier dans la configuration de votre logiciel ftp (filezilla ? autre ? )


Besoin d'aide pour votre blog ?, Article, page, catégorie, Un site en plusieurs langues. Coincés avec WPML ? Je vous aide à l'installer.

Hors ligne

 

#52 08-02-2010 22:01:22

Finder
Connaisseur WP
Date d'inscription: 07-02-2010
Messages: 13

Re: PHP5 depuis WordPress 2.8

Pour Freeheberg une méthode ?

Hors ligne

 

#53 10-02-2010 16:46:42

Visiteurdusoir
Membre WP
Date d'inscription: 07-02-2010
Messages: 4

Re: PHP5 depuis WordPress 2.8

Bonjour,

Ma configuration WP actuelle
- Version de WordPress : 2.9.1
- Version de PHP/MySQL :
- Thème utilisé : liasblue
- Extensions en place : aucune
- Nom de l'hebergeur : 1&1
- Adresse du site :

Problème(s) rencontré(s) : le même...éditeur visuel défaillant

J'ai suivi à la lettre les recommandations de Anonyme 2:
- création d'un fichier .htaccess

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

- transfert du fichier via filezilla sur la "racine": c'est à dire à la suite des 23 fichiers de base de WP.

Précision: n'étant pas expert, je ne peux créer un fichier avec l'extension php à partir du bloc-note de windows. Donc, je prends le dossier config sample, je le renomme .htaccess puis je le modifie en supprimant son contenu et en le remplaçant par les instructions ci-dessus.

L'éditeur visuel est toujours défaillant
Où est l'erreur ?

Merci

Hors ligne

 

#54 17-02-2010 13:08:10

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

Finder a écrit:

Pour Freeheberg une méthode ?

Bonjour,

quel offre avez vous,en regardant vite fait,l'offre gratuit,je vois que c'est par défaut sous php5.
http://www.firstheberg.com/offres/gratuit.php

Hors ligne

 

#55 17-02-2010 13:09:56

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

Visiteurdusoir a écrit:

Bonjour,

Ma configuration WP actuelle
- Version de WordPress : 2.9.1
- Version de PHP/MySQL :
- Thème utilisé : liasblue
- Extensions en place : aucune
- Nom de l'hebergeur : 1&1
- Adresse du site :

Problème(s) rencontré(s) : le même...éditeur visuel défaillant

J'ai suivi à la lettre les recommandations de Anonyme 2:
- création d'un fichier .htaccess

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

- transfert du fichier via filezilla sur la "racine": c'est à dire à la suite des 23 fichiers de base de WP.

Précision: n'étant pas expert, je ne peux créer un fichier avec l'extension php à partir du bloc-note de windows. Donc, je prends le dossier config sample, je le renomme .htaccess puis je le modifie en supprimant son contenu et en le remplaçant par les instructions ci-dessus.

L'éditeur visuel est toujours défaillant
Où est l'erreur ?

Merci

Bonjour,

le fichier .htaccess n' a pas d'extension .php  donc je ne comprends pas votre message.
utilisez plutôt notepad++ , mieux que le bloc note de windows.

Hors ligne

 

#56 09-03-2010 21:13:33

drey8074
Bavard WP
Date d'inscription: 24-02-2010
Messages: 248

Re: PHP5 depuis WordPress 2.8

merci beaucoup pour votre aide, j'ai eu ce même problème qui m'empêchait d'accéder à ma page admin, et j'ai pu le résoudre en moins de 20 min ! (un record)

Hors ligne

 

#57 22-03-2010 15:24:17

k-win
Bavard WP
Lieu: Brasil
Date d'inscription: 02-09-2008
Messages: 356
Site web

Re: PHP5 depuis WordPress 2.8

Salut les gens, petite question, j'ai un client avec un srv chez Orange et PHP Version 5.2.0-8+etch16 et il me faut php 5.2.5 pour faire tourner la derniere version de Mailpress. Une idée de ce que je pourrais coller dans le .htaccess ?

Ps: j'ai testé les différentes lignes en premiere page du topic sans succes.


EDIT: je viens de recevoir un mail du service technique qui me dis que ce n'est pas possible mais qu'une maj est prevue... un jour...

Dernière modification par k-win (22-03-2010 16:00:28)

Hors ligne

 

#58 05-04-2010 15:40:18

astbeaute
Bavard WP
Date d'inscription: 28-02-2010
Messages: 123
Site web

Re: PHP5 depuis WordPress 2.8

Bonjour! je suppose que pour online c'est par défaut aussi? Ou faut rajouter quelque chose???

Juste je me renseigne! Merci ange

Dernière modification par astbeaute (05-04-2010 15:41:19)


Mon bébé sous Wordpress: Ma petite fierté! créé en Février 2010
http://www.astucesbeaute.net

Hors ligne

 

#59 06-04-2010 23:08:28

Kastor
Connaisseur WP
Date d'inscription: 20-09-2009
Messages: 14

Re: PHP5 depuis WordPress 2.8

Bonjour,

Même problème que beaucoup de gens à savoir "Erreur 500" lors de l'installation de certains plugins.
Lorsque je rajoute le .htaccess à la racine, tout disparait: le blog, le paneau admin, etc.

J'ai tout essayé, toutes les lignes possibles, toutes les indentations possibles, j'ai même mit le fichier dans plusieurs dossiers mais mon site reste désespérément blanc. Que faire?

Je vais finir fou avec cette histoire, genre vraiment....
(et of course, je suis chez 1&1)

EDIT : http://www.wordpress-fr.net/support/vie … 27#p194727

Dernière modification par Kastor (07-04-2010 00:34:20)

Hors ligne

 

#60 23-04-2010 16:36:58

sunny
Habitué WP
Date d'inscription: 22-04-2010
Messages: 52
Site web

Re: PHP5 depuis WordPress 2.8

Bonjour,

je suis hebergé chez 1and1 et j'ai essayé aussi de mettre le php 5 avec la methode donnée ici et j'ai systématiquement une belle

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webadmin@kundenserver.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

qui bien sur s'en va lorsque j'enleve le .htaccess (qui etait bien mis à la racine du site)
à savoir que je n'ai pas de .htaccess à la racine mais dans un dossier /logs, mais je ne peux pas le toucher

à savoir aussi que j'ai plusieurs blogs hebergés sur cette adresse, 4 au total, dont 3 sont dans des sous-dossiers (avec des sous-domaines)


Edit :
j'ai regardé sur le support 1and1 qui donne bien la même procédure qu'ici

cependant, pour être sur que tout soit compatible, voici la ligne que j'ai insérer dans le .htaccess :

Code: html

AddType x-mapp-php5 .php .php3 .php4 .htm .html

pour que ce dernier fonctionne (surement parce que je suis sous mac et que TextEdit génere un .rtf) j'ai du récuperrer le .htaccess dans le fichier /logs, l'enregistrer dans la racine de mon site puis le réuploader et maintenant cela fonctionne

Dernière modification par sunny (23-04-2010 16:55:18)

Hors ligne

 

#61 12-05-2010 16:47:10

phlepont
Connaisseur WP
Lieu: AUVERGNE
Date d'inscription: 09-05-2010
Messages: 30
Site web

Re: PHP5 depuis WordPress 2.8

Bonjour,

Moi aussi j'ai testé et ça marche pas. Toujours erreur 500

Hors ligne

 

#62 15-05-2010 12:36:56

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

Bonjour,

j'ai un hébergement chez 1&1 ou j'ai 2 sites donc sur FTP 2 dossiers ,un pour chaque et dans chacun des sites j'ai mis le fichier .htaccess  avec les codes que j'ai donné,et aucun problème.
Le fichier était-il bien nommé ????        .htaccess      et non .htaccess.txt  ou .htaccess.html  ou .htaccess.php

Hors ligne

 

#63 15-05-2010 16:20:16

chamomor
Maitre Wordpress
Lieu: Paris
Date d'inscription: 17-11-2008
Messages: 2166
Site web

Re: PHP5 depuis WordPress 2.8

sunny a écrit:

Bonjour,

je suis hebergé chez 1and1 et j'ai essayé aussi de mettre le php 5 avec la methode donnée ici et j'ai systématiquement une belle

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webadmin@kundenserver.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

qui bien sur s'en va lorsque j'enleve le .htaccess (qui etait bien mis à la racine du site)
à savoir que je n'ai pas de .htaccess à la racine mais dans un dossier /logs, mais je ne peux pas le toucher

à savoir aussi que j'ai plusieurs blogs hebergés sur cette adresse, 4 au total, dont 3 sont dans des sous-dossiers (avec des sous-domaines)


Edit :
j'ai regardé sur le support 1and1 qui donne bien la même procédure qu'ici

cependant, pour être sur que tout soit compatible, voici la ligne que j'ai insérer dans le .htaccess :

Code: html

AddType x-mapp-php5 .php .php3 .php4 .htm .html

pour que ce dernier fonctionne (surement parce que je suis sous mac et que TextEdit génere un .rtf) j'ai du récuperrer le .htaccess dans le fichier /logs, l'enregistrer dans la racine de mon site puis le réuploader et maintenant cela fonctionne

Bonjour, ton fichier .htaccess (sans extension) chez 1&1 ne doit contenir que

Code: html

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

et si permaliens cela donnera :

Code: html

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

ce fichier doit aller dans le dossier où est le blog, soit à la racine soit dans le dossier du blog

Hors ligne

 

#64 16-05-2010 12:13:54

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

tout est dans le 1er message !!!!

Hors ligne

 

#65 14-01-2011 11:32:18

aromaets
Membre WP
Date d'inscription: 14-01-2011
Messages: 3

Re: PHP5 depuis WordPress 2.8

Bonjour, Comment les moteurs de recherche pointe sur le blog WORDPRESS sachant qu'il est à l'intérieur d'un dossier exemple : mondomaine.com/blog

Hors ligne

 

#66 14-01-2011 13:53:52

Lumière de Lune
Admin nomade
Lieu: El Jadida
Date d'inscription: 15-08-2007
Messages: 15970
Site web

Re: PHP5 depuis WordPress 2.8

Pouvez vous ouvrir votre propre question dans le forum support, le sujet n'a rien à voir avec ce fil ?


Besoin d'aide pour votre blog ?, Article, page, catégorie, Un site en plusieurs langues. Coincés avec WPML ? Je vous aide à l'installer.

Hors ligne

 

#67 20-03-2011 23:11:33

Lypse
Membre WP
Date d'inscription: 29-01-2011
Messages: 8

Re: PHP5 depuis WordPress 2.8

Bonsoir,

Désolé de relancer le sujet mais j'essaye depuis ce soir de mettre mon site internet en ligne.

J'ai eu le problème du fichier .htaccess chez 1&1.

Je l'ai donc créé, mais j'ai toujours des erreurs qui s'affichent.

Code: html

Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-login.php on line 354

Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-login.php on line 366



Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-login.php on line 354

Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-login.php on line 366

Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-includes/pluggable.php on line 693

Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-includes/pluggable.php on line 694

Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-includes/pluggable.php on line 695

Warning: Cannot modify header information - headers already sent by (output started at /homepages/4/d362058206/htdocs/wp-content/themes/Black_Blue_2/functions.php:45) in /homepages/4/d362058206/htdocs/wp-includes/pluggable.php on line 897

J'ai mi ce code dans mon .htacces, ce qui m'a permis d'installer mon thème, mais maintenant j'ai toutes les erreurs cité plus haut. Je n'arrive même plus à aller dans le tableau de bord et pourtant j'ai réussi il n'y a pas longtemps à publier des articles ou il y avais des erreurs qui j'essayais de les publier.

Code: html

 
      AddType x-mapp-php5 .php
      AddHandler x-mapp-php5 .php
      # BEGIN WordPress
      <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
      </IfModule>

Cela vient t'il de mon fichier .htaccess ou alors de mon code en lui même ?

Hors ligne

 

#68 21-03-2011 17:13:44

chamomor
Maitre Wordpress
Lieu: Paris
Date d'inscription: 17-11-2008
Messages: 2166
Site web

Re: PHP5 depuis WordPress 2.8

Bonjour
C'est le thème qui est fautif, repasse avec le thème par défaut pour vérifier la chose.

Hors ligne

 

#69 21-03-2011 20:38:37

Lypse
Membre WP
Date d'inscription: 29-01-2011
Messages: 8

Re: PHP5 depuis WordPress 2.8

Effectivement c'était mon thème qui posé défaut. Je voudrais savoir s'il vous plait pour quoi mon thème ne fonctionnait pas, peut être parce que je l'ai créé moi-même. Pourtant il fonctionnait bien en local hmm

Merci de ta réponse en tout cas smile

Hors ligne

 

#70 10-05-2011 10:55:36

jokerman33
Membre WP
Date d'inscription: 10-05-2011
Messages: 1

Re: PHP5 depuis WordPress 2.8

Bonjour à tous,
je rencontre le même problème.
Lorsque j'appelle l'url d'installation : mondom.com/wp-admin/install.php
j'ai  ce message d' erreur :

Fatal error: Call to undefined function __() in /home/xkfbwwle/public_html/wp-admin/includes/file.php on line 11

j'ai essayé toutes les méthodes via htaccess trouvée sur le forum, soir j'ai une erreur 500, soit la page d'install me dit que php n'est pas installé.

Avez-vous des suggestions ?

d'autre part, j'ai pas bien compris, mon serveur est déjà en php 5 quel intérêt de rajouter une ligne dans le htaccess afin d'activer php 5 , dans ce cas (php 5 déjà installé), si le htaccess n'est pas nécessaire, d'ou viens le problème ?

Ma configuration WP actuelle
- Version de WordPress : wordpress-3.1.2-fr_FR
- Version de PHP/MySQL : PHP Version 5.2.13/Mysql 5.0.92
- Thème utilisé : -
- Extensions en place : -
- Nom de l'hebergeur : hosteur (serveur dédié)

Dernière modification par jokerman33 (10-05-2011 11:15:18)

Hors ligne

 

#71 11-05-2011 19:58:03

chamomor
Maitre Wordpress
Lieu: Paris
Date d'inscription: 17-11-2008
Messages: 2166
Site web

Re: PHP5 depuis WordPress 2.8

Lypse a écrit:

Effectivement c'était mon thème qui posé défaut. Je voudrais savoir s'il vous plait pour quoi mon thème ne fonctionnait pas, peut être parce que je l'ai créé moi-même. Pourtant il fonctionnait bien en local hmm

Merci de ta réponse en tout cas smile

Hello,
loin de moi l'idée de refuser de t'aider, mais pour le savoir il eut fallu analyser ton fichier function.php
c'est pas un problème général absolu, mais comment tu as codé, il suffit parfois d'une virgule manquante ou de trop...

Hors ligne

 

#72 14-05-2011 14:35:03

noaneo
Blogueur Fou
Date d'inscription: 18-03-2011
Messages: 24772
Site web

Re: PHP5 depuis WordPress 2.8

bonjour,il serait préférable de créer un propre sujet de discussion pour le souci de votre thème,rien n'avoir avec le sujet de discussion.
idem pour jokerman33,votre souci n'a pas l'air de venir du php5 puisque vous dites que vous êtes déjà sous php5 donc rien à rajouter au fichier .htaccess


Chez 1&1 ,désormais en passant par "Accès Client" puis cadre "Domaines et Espace Web" puis" Version Globale  PHP"
là on peut choisir la version du php soit 4 ou 5 , plus besoin de toucher au fichier .htaccess


-Amen,Infomaniak  ,pas de fichier .htaccess à toucher tout se passer par la panneau de contrôle de l'hébergeur.

Dernière modification par rvzen (08-06-2011 13:27:09)


signature:
noaneo
les MP seront supprimés sans être lus ,donc pas la peine de m'écrire,merci.

Hors ligne

 

#73 28-06-2011 18:48:39

jin
Membre WP
Date d'inscription: 28-06-2011
Messages: 2

Re: PHP5 depuis WordPress 2.8

Bonjour,

Je suis sous Free. J'installe WP.
Quand quand je me connecte a mon compte http://adressedevotresite/wp-admin/install.php. apres avoir tout téléchargé par Filezilla à la racine de mon compte comme indiqué, j'ai le msg d'erreur : "Une ou plusieurs tables de votre base de données sont indisponibles. La base de données a peut-être besoin d’être réparée."
J'ai fait la reparation -> meme resultat
J'ai ajoute le fichier .htaccess avec php 1 dedans -> meme resultat

Pourriez vous m'aider ?

Merci

Hors ligne

 

#74 28-06-2011 19:31:16

noaneo
Blogueur Fou
Date d'inscription: 18-03-2011
Messages: 24772
Site web

Re: PHP5 depuis WordPress 2.8

merci de créer une nouvelle discussion, en prenant bien le soin de remplir le questionnaire


signature:
noaneo
les MP seront supprimés sans être lus ,donc pas la peine de m'écrire,merci.

Hors ligne

 

#75 30-06-2011 12:17:12

franzoui
Habitué WP
Date d'inscription: 27-06-2011
Messages: 55

Re: PHP5 depuis WordPress 2.8

Pour Infomaniak il faut rajouter quoi? Le fichier .htaccess je l'ai déjà créé pour les permaliens.

Hors ligne

 

Pied de page des forums

Propulsé par PunBB 1.2.23
© Copyright 2005-2006 WordPress France

[ Generated in 0.258 seconds, 34 queries executed ]