Annonce

Faites la différence entre le service WordPress.com et l'application libre WordPress.

Mettez-vous à jour ! WordPress 3.9 est disponible en français.

Annonce 1 : Le Codex en français a besoin de vous pour avancer !
Annonce 2 : Avant de poster, n'oubliez pas de faire une petite recherche et de lire les règles de ce forum.
Annonce 3 : Lisez notre blog, il regorge de bonnes informations.
Annonce 4 : Rejoignez-nous sur Facebook, Google + et sur Twitter

#1 30-11-2009 11:18:21

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

PHP5 depuis WordPress 2.8

Bonjour,


Depuis Wordpress 2.8 pour éviter des messages d'erreurs ou/et des erreurs  il faut être sous php5, 5.3 depuis Wordpress 3.3
C'est grâce au fichier .htaccess   qui se trouve à la racine ou à la base de votre blog (FTP, là où sont les fichiers de Wordpress, à la hauteur de wp-admin,wp-content,wp-includes,inedex.php etc..),il faudra le récupérer et rajouter une ligne,si celui ci est absent il faudra le créer grâce un éditeur de texte style Notepad++.

Pour Free
Dans le fichier .htaccess  rajouter cette ligne
    php 1

php 1

enregistré et envoyé par FTP à la racine de votre blog.

si erreur ou souci ,essayer ceci,merci à Chamomor pour l'info
php 1
SetEnv PHP_VER 5

php 1
SetEnv PHP_VER 5

Pour OVH
Dans le fichier .htaccess  rajouter cette ligne
Selon les versions désirées:
PHP 5.2, ajouter: SetEnv PHP_VER 5
PHP 5.3, ajouter: SetEnv PHP_VER 5_3
PHP 5.4, ajouter: SetEnv PHP_VER 5_4

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
SetEnv PHP_VER 5

enregistré et envoyé par FTP à la racine de votre blog.

Pour 1&1
Mieux : activer le php5 global au niveau du compte, le choix de la version dans l'espace client:
http://img526.imageshack.us/img526/826/php51and1.jpg
Moins bien :
Dans le fichier .htaccess  rajouter cette ligne
   AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

enregistré et envoyé par FTP à la racine de votre blog.

http://img59.imageshack.us/img59/9505/ftpfree.th.png

Les fichiers .htaccess sont des exemples.

si vous avez besoin d'un fichier phinfo.php , vous devez le créer (si l'hébergeur ne l'a pas déjà fait,bien sûr )
avec un éditeur de texte (Notepad ++) et mettre une page vierge ce code

Code: html

<?php
phpinfo();
?>

enregistré le fichier sous le nom de phpinfo.php
et l'envoyer à la racine de votre site.

Dernière modification par Lupi (09-01-2010 11:55:18)

Hors ligne

 

#2 30-11-2009 13:22:22

ifranck
Connaisseur WP
Date d'inscription: 01-10-2009
Messages: 44
Site web

Re: PHP5 depuis WordPress 2.8

Pour 1&1, certains webmasters conseillent :
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Aux experts, à quoi sert AddHandler x-mapp-php5 .php !!!

Hors ligne

 

#3 30-11-2009 13:30:50

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

Moi je n'ai que AddType x-mapp-php5 .php  dans mon fichier .htaccess et ça fonctionne.
AddHandler

Hors ligne

 

#4 30-11-2009 18:28:35

ifranck
Connaisseur WP
Date d'inscription: 01-10-2009
Messages: 44
Site web

Re: PHP5 depuis WordPress 2.8

Bien. Merci.

Hors ligne

 

#5 04-12-2009 11:59:28

manu59
Maître WP
Lieu: Dans ch'nord
Date d'inscription: 11-11-2009
Messages: 1258

Re: PHP5 depuis WordPress 2.8

bonjour Anonyme 2, je n'ai pas de fichier .hatcess, comment le créer sous mac ? je suis sous ovh
hier j'ai voulu mettre le message de sécurité que j'ai eu en news dans mon admin "libretto : Renforcer la sécurité de WordPress", j'ai créer le fichier mais quand il était en ligne j'ai eu un gros message d'erreur et que des pages blanches partout, plus d'admin, plus de site


autodidacte sous le signe de la lenteur
- je cherche des conseils pour être performante avec WP quand on est seule et sans emploi, lente car j'ai de graves problèmes de santé. Merci.

Hors ligne

 

#6 04-12-2009 13:04:49

manu59
Maître WP
Lieu: Dans ch'nord
Date d'inscription: 11-11-2009
Messages: 1258

Re: PHP5 depuis WordPress 2.8

merci peux tu me donner le lien car j'ai trouve que pour wp mu


autodidacte sous le signe de la lenteur
- je cherche des conseils pour être performante avec WP quand on est seule et sans emploi, lente car j'ai de graves problèmes de santé. Merci.

Hors ligne

 

#7 04-12-2009 13:16:20

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

Merci oliviert
Manu59,il faut juste un éditeur de texte,vous avez bien ça sur mac ?
Il suffit de copier le colle ,enregistrer puis l'envoyer A LA RACINE DE VOTRE BLOG.

Hors ligne

 

#8 04-12-2009 13:31:07

manu59
Maître WP
Lieu: Dans ch'nord
Date d'inscription: 11-11-2009
Messages: 1258

Re: PHP5 depuis WordPress 2.8

oui je viens de trouver avec text edit, mais quand j'ai mis le code recommandé, ça a tout zappé sur le site et l'admin


autodidacte sous le signe de la lenteur
- je cherche des conseils pour être performante avec WP quand on est seule et sans emploi, lente car j'ai de graves problèmes de santé. Merci.

Hors ligne

 

#9 04-12-2009 13:35:46

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

il serait plus facile si vous créez votre sujet de discussion.

Hors ligne

 

#10 04-12-2009 13:36:28

manu59
Maître WP
Lieu: Dans ch'nord
Date d'inscription: 11-11-2009
Messages: 1258

Re: PHP5 depuis WordPress 2.8

oui je vais le faire


autodidacte sous le signe de la lenteur
- je cherche des conseils pour être performante avec WP quand on est seule et sans emploi, lente car j'ai de graves problèmes de santé. Merci.

Hors ligne

 

#11 04-12-2009 13:57:53

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

où est-il ?
Vous avez mis ce code

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
SetEnv PHP_VER 5

à la racine de votre blog,par FTP, le fichier bien nommé "   .htaccess   " ?

Hors ligne

 

#12 04-12-2009 14:00:10

Lumière de Lune
Admin nomade
Lieu: El Jadida
Date d'inscription: 15-08-2007
Messages: 15954
Site web

Re: PHP5 depuis WordPress 2.8

Il me semble plus simple de mettre un fichier php.ini, au lieu de modifier le htaccess, non ?


Besoin d'aide pour votre blog ?, Article, page, catégorie, Un site en plusieurs langues. Coincés avec WPML ? Je vous aide à l'installer.

Hors ligne

 

#13 04-12-2009 14:02:47

manu59
Maître WP
Lieu: Dans ch'nord
Date d'inscription: 11-11-2009
Messages: 1258

Re: PHP5 depuis WordPress 2.8

bon et bien maintenant plus moyen de me connecter sur la page : The requested URL /club/wp_loging.php was not found on this server.
alors qu'hier j'y ai travaillé, et j'ai mis ce foutu fichier, tout est sur le serveur


autodidacte sous le signe de la lenteur
- je cherche des conseils pour être performante avec WP quand on est seule et sans emploi, lente car j'ai de graves problèmes de santé. Merci.

Hors ligne

 

#14 04-12-2009 14:07:06

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

Lumière de Lune a écrit:

Il me semble plus simple de mettre un fichier php.ini, au lieu de modifier le htaccess, non ?

Chez les 3 hébergeurs que je cite,c'est toujours le fichier .htaccess qui faut toucher pour passer sous php5 , jamais vu php.ini   que je ne connais pas sad

Hors ligne

 

#15 04-12-2009 14:08:40

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

manu59 a écrit:

bon et bien maintenant plus moyen de me connecter sur la page : The requested URL /club/wp_loging.php was not found on this server.
alors qu'hier j'y ai travaillé, et j'ai mis ce foutu fichier, tout est sur le serveur

C'est pourquoi je vous conseille d'ouvrir un sujet car il faudrait des infos,nom d'hébergeur,enfin là je suppose OVH,
version de wordpress,url de votre site.
Pour l'instant supprimer ce fichier pour accéder à votre site

Hors ligne

 

#16 04-12-2009 14:21:45

manu59
Maître WP
Lieu: Dans ch'nord
Date d'inscription: 11-11-2009
Messages: 1258

Re: PHP5 depuis WordPress 2.8


autodidacte sous le signe de la lenteur
- je cherche des conseils pour être performante avec WP quand on est seule et sans emploi, lente car j'ai de graves problèmes de santé. Merci.

Hors ligne

 

#17 04-12-2009 16:37:48

patoudel
Bavard WP
Lieu: Haute-Gironde
Date d'inscription: 16-02-2008
Messages: 227
Site web

Re: PHP5 depuis WordPress 2.8

Bravo Anonyme 2 pour cet "épinglage"wp

Hors ligne

 

#18 04-12-2009 18:29:32

Anonyme 2
Blogueur Fou
Date d'inscription: 22-05-2007
Messages: 11147

Re: PHP5 depuis WordPress 2.8

Merci wink

Hors ligne

 

#19 06-12-2009 07:01:04

ludo2009
Membre WP
Date d'inscription: 06-12-2009
Messages: 1

Re: PHP5 depuis WordPress 2.8

Bonjour à tous,

Je suis un grand débutant en informatique, et je viens d'acheter une méthode pour créer mon blog avec wordpress. Je rencontre toutes les difficultés que peut rencontrer une personne qui n'a pas de bases en info.
le manuel dit :
1- créer une copie du fichier wp-config-sample.php et enregistrez-le sous le nom wp-config.php

- lorsque je sélectionne le fichier en question et que je fais ctrl+c et ctrl+v pour créer une copie, rien ne se passe. Pourtant une copie ça veut bien dire que je dois avoir 2 fichiers du même nom à l'écran?
- ensuite, on me demande de renommer le fichier. Je fais un clic droit sur le fichier, mais il n'y a pas ''renommer''. J'ai lu dans un forum qu'il fallait le renommer en téléchargeant winrar, chose que j'ai essayé de faire hier, et qui a fonctionné, mais je me suis retrouvé avec les dossiers enregistrés à l'intérieur de winrar?

2- le fichier "wp-config.php" dans l'éditeur "notepad++''
On me dit de faire glisser le fichier dans la fenêtre ouverte de l'éditeur. J'ai essayé plusieurs fois, mais ça donne rien.

Je précise qu'à ce stade je n'ai pas encore choisi d'hébergeur. C'est important de le choisir avant de faire toutes ces manips, ou il est encore temps d'en choisir un à l'étape suivante : réglages de la base de données MySQL (commentaire : prochain rendez-vous sûrement).

Hors ligne

 

#20 06-12-2009 07:13:34

Lumière de Lune
Admin nomade
Lieu: El Jadida
Date d'inscription: 15-08-2007
Messages: 15954
Site web

Re: PHP5 depuis WordPress 2.8

1- il semble que vous n'ayez pas encore décompressé le fichier téléchargé.
Il faut le faire avant toute opération. Vous avez à ce moment là un dossier, avec des fichiers que vous pouvez manipuler normalement.

2- Il suffit de faire plus simple : ouvrir notepad++ avec un double clic, et ensuite menu fichier ouvrir

Maintenant à lire vos questions vous êtes un très très très grand débutant en informatique. C'est à dire que les questions que vous posez ne concernent même pas l'utilisation de wordpress, mais l'utilisation de base de windows. Il faudrait peut être vous familiariser un peu avec l'outil informatique avant de commencer à créer votre blog

Pour répondre à votre dernière question, oui il est très important d'avoir un hébergement. Il est "possible" de faire un blog 'en local" sur son ordinateur, mais dans ce cas là il n'est pas accessible par le web, et de plus cela demande quand même une petite expérience en informatique.

Si votre premier objectif est d'avoir un blog, je vous conseille tout simplement de vous enregistrer sur le site wordpress.com qui vous propose des blogs préconfigurés, et tout prêts à l'emploi. Cela vous permettra d'apprendre l'utilisation de cet outil, et cela sera sans doute plus simple.


Besoin d'aide pour votre blog ?, Article, page, catégorie, Un site en plusieurs langues. Coincés avec WPML ? Je vous aide à l'installer.

Hors ligne

 

#21 09-12-2009 20:23:22

baaf19
Connaisseur WP
Date d'inscription: 29-11-2009
Messages: 24

Re: PHP5 depuis WordPress 2.8

Bonjour,

suite à cette fameuse erreur 500, j'ai essayé de passer sous php5 en suivant ton tutoriel. (je suis chez 1&1).

Voici mon fichier .htaccess:

Options +Indexes
Satisfy any
Order Deny,Allow
Allow from 172.17.0.0/16
Allow from 212.227.35.64/27
Allow from 212.227.34.151
Allow from 212.227.34.190
Deny from all
RemoveType .html .gif
AuthType Basic
AuthName "Access for /logs"
AuthUserFile /kunden/homepages/0/d310165737/htpasswd
require user u56453917


J'ai beau mettre la ligne  AddType x-mapp-php5 .php eu début ou à la fin du fichier, j'ai toujours la même erreur 500.

En cherchant sur le net, j'ai vu que mon fichier .htaccess ne ressemble pas du tout à celui d'autres utilisateurs, est-ce que ça pourrait être le problème?

Hors ligne

 

#22 09-12-2009 22:06:44

baaf19
Connaisseur WP
Date d'inscription: 29-11-2009
Messages: 24

Re: PHP5 depuis WordPress 2.8

PS:

J'ai trouvé cette combine sur le net, mettre 2 lignes au lieu d'1:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Résultat, ça ne marche toujours pas.

Ca m'énerve, ça m'énerve..........angryfire_gifangryfire_gifangryfire_gifangryfire_gifangryfire_gif

Hors ligne

 

#23 13-12-2009 07:10:06

sylvaindeaire
Bavard WP
Lieu: Pas de Calais (62) (France)
Date d'inscription: 19-07-2009
Messages: 110
Site web

Re: PHP5 depuis WordPress 2.8

moi j'ai un problème depuis peu sous free je suis retomber en php 4 sad
j'avais pourtant bien le htacces sur mon serveur mais je ne c'est pas ce qui c'est passer tout d'un coup sa à causé une erreur interne sad alors j'ai retirer ce fichier htacces et l'erreur était enlever et mon site est de nouveau accéssible, mais impossible de pouvoir me remettre ce fichier htacces pour revenir en php 5 que faire ???? sad

Hors ligne

 

#24 15-12-2009 21:46:59

herpad
Connaisseur WP
Date d'inscription: 04-12-2009
Messages: 12

Re: PHP5 depuis WordPress 2.8

Je trouve bien le fichier .htaccess mais il ressemble en tout point à celui de baaf19... (je suis aussi chez 1and1)

Quelqu'un sait comment où placer cette ligne ?

Merci


Celui qui n'y connaissait rien en php... et puis il y a eu wordpress !

Hors ligne

 

#25 17-12-2009 19:35:16

herpad
Connaisseur WP
Date d'inscription: 04-12-2009
Messages: 12

Re: PHP5 depuis WordPress 2.8

Bonsoir,

Pour ceux qui sont hébergés chez 1and1, il suffit de créer un fichier avec le bloc texte, d'insérer juste la ligne

"AddType x-mapp-php5 .php"

et de l'envoyer à la racine du site ;-)

J'ai testé et ça marche !!!


Celui qui n'y connaissait rien en php... et puis il y a eu wordpress !

Hors ligne

 

Pied de page des forums

Propulsé par PunBB 1.2.23
© Copyright 2005-2006 WordPress France

[ Generated in 2.224 seconds, 32 queries executed ]